Here's another bundle of test fixes, focused on making the tests faster and more reliable. Based on my earlier series cleaning up the port forwarding data structures. David Gibson (12): test: Add wait_for() shell helper test: Remove unnecessary sleeps from layout functions test: Remove unnecessary sleeps from shutdown tests test: More robust wait for pasta/passt to be ready test: Use --config-net for namespace setup test: Simplify data handling for transfer tests test: Remove unneccessary pane naming from layout_two_guests clang-tidy: Disable 'readability-identifier-length' cppcheck: Avoid excessive scanning due to system headers cppcheck: Run quietly Makefile: Simplify getting target triple for compiler cppcheck: Add target specific headers Makefile | 32 +++---- test/.gitignore | 1 + test/Makefile | 15 ++- test/lib/context | 4 +- test/lib/layout | 24 ----- test/lib/setup | 32 +++---- test/lib/util | 8 ++ test/passt.mbuto | 6 +- test/passt/shutdown | 1 - test/passt/tcp | 53 +++++------ test/passt/udp | 29 +++--- test/passt_in_ns/shutdown | 1 - test/passt_in_ns/tcp | 187 ++++++++++++++++---------------------- test/passt_in_ns/udp | 93 ++++++++----------- test/pasta/tcp | 79 +++++++--------- test/pasta/udp | 43 ++++----- test/two_guests/basic | 2 +- 17 files changed, 250 insertions(+), 360 deletions(-) -- 2.37.3